[Yardım]  Excele Ayrı Ayrı Girilen Tüm Değerlerin Tek Bir Hücrede Topl

VBA Makrolar ile ilgili sormak istedikleriniz, yapmak istedikleriniz hakkında yardım alabileceğiniz bölümdür.

Excele Ayrı Ayrı Girilen Tüm Değerlerin Tek Bir Hücrede Topl

İleti#1)  t3qnee » 15 Haz 2021 10:10

Selamlar,

https://flic.kr/p/2m5yMrX

Fotoğraftaki gibi bir YKS'ye hazırlanan öğrenciler için öz değerlendirme projesi hazırlıyorum. Yandaki menüde dropdown menüden konuyu seçip diğer verileri girdikten sonra yandaki tabloda verilerin gözükmesini ve öğrencilerin kendilerini tablo üzerinde conditional formatting, sort of, charts gibi özelliklere makro ile rahat kullandırıp kişilere kendileri hakkında bilgi vermek istiyorum.

Asıl sorum şu şekilde:
İki tarafta konular eşitse değerleri direkt ataması için bir if fonksiyonu atadım. Örnek: =EĞER($B$3=K4;$D$3;0)
Ama bu sefer menüdeki veriyi değiştirdiğimde tablodaki veriler kayboluyor veya değişiyor.
Ben menüde her veriyi girip bir butona basıp tabloya konuya göre değerin girilmesini ve tekrar tekrar veri girdiğimde eski veri ile toplanmasını istiyorum.

Bunu hangi makro ile yapabilirim yardımcı olursanız sevinirim. Bu proje benim için çok anlam ifade ediyor, Teşekkürler.
Kullanıcı avatarı
t3qnee
 
Kayıt: 15 Haz 2021 10:05
Meslek: Öğrenci
Yaş: 17
İleti: 1
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul/Beylikdüzü

Cevap: Excele Ayrı Ayrı Girilen Tüm Değerlerin Tek Bir Hücre

İleti#2)  icemail » 18 Haz 2021 20:22

Merhaba
Aşağıdaki kodu inceleyin lütfen.


Kod: Tümünü seç
Dim i As Long
Dim Lr as Long

Lr = Cells(Rows.Count, 3).End(xlUp).Row
For i=1 to Lr
    If Range("C" & i).Value = Range("K" & i +1).Value Then
        Range("D" & i).Value = "0"
    Else
        'Eşit değilse bunu yap     
    End If
Next i
Kullanıcı avatarı
icemail
Yeni Başlamış
 
Kayıt: 29 May 2015 09:56
Meslek: Diğer
Yaş: 38
İleti: 41
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: İstanbul

Cevap: Excele Ayrı Ayrı Girilen Tüm Değerlerin Tek Bir Hücre

İleti#3)  selcuk100 » 29 Haz 2021 13:34

istediğin şeyleri yapacak dosyayı hazırladım.
veri giriş yerlerini değiştirmediğin sürece hata vermez.
tarih girişlerini yan yana yaptım alt alta yapınca düzen bozuluyor çünkü.

konuları aktar butonu : k sütunundaki konuların combo'ya aktarır
bilgileri aktar butonu : D3, F3, H3 deki verileri uygun konuya değerleri ekleyerek ekler

umarım yardımı olur.


dosya linki
https://dosya.co/4e06zqd7uk9c/Kitap1.xls.html
Kullanıcı avatarı
selcuk100
 
Kayıt: 29 Haz 2021 11:46
Meslek: bilgisayar
Yaş: 36
İleti: 5
 
Cinsiyet: Bay
Bulunduğunuz İl / Semt: izmir


Forum Genel Makro Soruları

Online Kullanıcılar

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir

Bumerang - Yazarkafe